Smart Car

Forums > Ask the Expert anything about smart > Passion SatNav/CD

smart hq
Passion satnav/cd
Previous | 12 | Next

I've just (literally this afternoon!) taken delivery of a brand new Smart fortwo Passion Cabrio. Based on what I'd seen at the showroom, I was expecting a Pioneer satnav/CD unit - but it seems that the one installed in my car is not branded with any particular make. Does anyone know if I have an older version unit? Or indeed is it a NEWER version than the one I saw? Just curious and want to make sure that I have the most up-to-date fittings. This aside, I was chuffed with the car on its first litle journey home :D
Thanks folks!

you've probably got the newer version from the september face lift, but i don't know who makes it, i would'nt get to upset over the pioneer unit just read some of the posts on here about them, also the pioneer avic range of radio's are aftermarket units and will always look retro-fitted on any car, i think the new radio/nav that smart have fitted blends a bit better with the dash, although i've only seen pictures so far i think it does look smart (lol)

congrats on the new purchase!!

bet you will love the car :)

JJ

--

www.quidco.com <<< CLICK - £70 cashback on my car insurance Sept 2011

www.forfour.co.uk - forfour technical solutions
www.evilution.co.uk

Thanks dj - I'll relax now :-) And thanks problem child - I have a feeling I'm definitely going to love it!

Does your new sat nav look like this?

If it is that one, i've just collected my new smart car with that in and think it's great. Let me know if you have any more questions about it.

--

Follow smart on twitter.
Find us on facebook.
Watch us on YouTube.
For all things smart: www.destinationsmart.co.uk

It is indeed like the one in the article Martine... and I love it! Thanks for sending the link - I'm no longer worried about not seeing the word Pioneer on the front of the unit :D

I've just got a new ForTwo Brabus with the new Navigation Unit. Everytime I change the units to Miles it keep reverting back to Kilometers. Anyone else having the same issue?

Other than that, I love the car :-)

I've recently taken delivery of a Brabus with the new Sat Nav / ICE unit too and have experienced a similar problem. The Sat Nav seems to change back to Km if left overnight but not if switched off and re-started after a few hours. One other thing I've noticed is that it doesn't remember the last track being played on a connected iPod if switched off overnight and starts playing the the first alphabetically sorted track next morning.

All in all some very minor niggles and the new unit is otherwise an excellent piece of kit. Very please with the car too, though the 225 section rear tyres are (not surprisingly) absolutely useless in the snow so have invested in some winter tyres as I live in Aberdeen.

The new satnav unit is made by Bosch.

--

Tony (J500ANT)
http://www.thesmartclub.com

Hi All

Will check re the ipod track and km/miles issues on Monday and come back to you.

Martine :)

--

Follow smart on twitter.
Find us on facebook.
Watch us on YouTube.
For all things smart: www.destinationsmart.co.uk

I've got the KM/Mile issue along with no TMC. It's also surprising that there is no way of searching for a track in the iPod mode. I have an iPod Classic connected to mine and it's almost impossible to navigate. In my old Merc you could search by first letter of track / artist / album name.

Martine @ smart UK said...

Hi All

Will check re the ipod track and km/miles issues on Monday and come back to you.

Martine :)

Hi Again
I'm lending my car to the technical team for them to investigate. As soon as I can I'll let you all have an update.
Martine

--

Follow smart on twitter.
Find us on facebook.
Watch us on YouTube.
For all things smart: www.destinationsmart.co.uk

Martine @ smart UK said...

Hi All

Will check re the ipod track and km/miles issues on Monday and come back to you.

Martine :)

Hi Martine,

The other problem with mine is that it doesn't work at all via cable (bluetooth is OK) on an iPhone (or I believe iPod Touch) with 4.1 or higher software. This means any device bought or upgraded since early September. Again, this is likely to be something which could be resolved through a software update to the stereo. I mentioned in another thread that Fiat/Alfa Romeo make the updates to their system online so you create a USB stick to update your car with. This would be awesome if the same was possible?

Hi all, quick update, we've contacted the factory to ask about the 3 issues above and will let you know when we hear back.
Martine

--

Follow smart on twitter.
Find us on facebook.
Watch us on YouTube.
For all things smart: www.destinationsmart.co.uk

If we're adding quibbles to the functioning of the unit, when my iPod touch is connected, the display of track and time elapsed will frequently freeze, usually until the next time I switch off and return to the car. The forward/back/stop etc buttons still work perfectly, but the old track still stays on the display.

David

Tony said...

The new satnav unit is made by Bosch.

in their Blaupunkt factory.

--

www.evilution.co.uk

Orangezorki said...

If we're adding quibbles to the functioning of the unit, when my iPod touch is connected, the display of track and time elapsed will frequently freeze, usually until the next time I switch off and return to the car. The forward/back/stop etc buttons still work perfectly, but the old track still stays on the display.

David

--

Relayer69

[*] I also have the problem above with the display freezing.
Additionally, does anyone know a way of being able to enter full postcodes because the European setting makes the SatNav less practical.

--

Relayer69

Hi All

We're still waiting to hear from the factory but will keep you posted.

Martine

--

Follow smart on twitter.
Find us on facebook.
Watch us on YouTube.
For all things smart: www.destinationsmart.co.uk

I've just bought a new Passion Coupe mhd equipped with (the new Bosch) high line radio/satnav. Though I'm very impressed with the satnav I have two problems...
1. Auto reversion to kilometres (already reported by others)
2. I'm having trouble using the 'plot GPS track' function. I've inserted a 4GB Sandisk card into the slot and 'activated' plotting before a journey. Following my journey I removed the card, moved the plot file created from the journey to my computer and attempted to view through Google Earth. All I get on the map is a single point that marked my starting point, with no 'track' at all. I'm doing something wrong but I can't understand just what. Can anyone help?

Previous | 12 | Next

Jump to forum: Go

All forums are moderated and should not be used to promote businesses or products. Please create your own profile or group for this. We reserve the right to remove any comment we feel is inappropriate at any time.

smart login
Connect with Facebook